Recent posts

TypePostAuthorRepliesLast updated
Forum topicEvaluating MPG Anonymous111 years 30 weeks ago
Forum topicTorque gauge drops to zero...... Marty Weston411 years 31 weeks ago
Forum topicDefault Codes Anonymous411 years 31 weeks ago
Forum topicTransmission fluid temperature BradnChristine211 years 31 weeks ago
Forum topic2004 Allegro Bus by Tiffin with a Cummins engine. Anonymous311 years 31 weeks ago
Forum topicRV-C omniscope hogbreth.111 years 32 weeks ago
Forum topicIntake Manifold Temperature Ted Bryan011 years 33 weeks ago
Forum topicTorque and HP on MB 926 engine Ted Bryan211 years 33 weeks ago
Forum topicThanks to Forum alnlil011 years 33 weeks ago
Forum topicFuel Raedings Anonymous511 years 34 weeks ago
Forum topicVersion 4 Software Ready for the VMS 200 EL. Martin Perlot211 years 34 weeks ago
Forum topicVMSpc HP Accuracy? BradnChristine411 years 36 weeks ago
Forum topicFreightliner/Mercedes VMSpc Compatability snickster611 years 36 weeks ago
Forum topicRolling MPG Buffer Size Anonymous511 years 36 weeks ago
Forum topicWhat a disappointment! Anonymous511 years 39 weeks ago
Forum topicVMSpc adapter Anonymous111 years 39 weeks ago
Forum topicProgram not compatable with Vista? Marty Weston211 years 39 weeks ago
Forum topicTireSafeGuard™ Dick Zeiter.111 years 40 weeks ago
Forum topicDoes Transmission connector = Engine connector ? Anonymous111 years 40 weeks ago
Forum topicCable Length SteveAndBev511 years 40 weeks ago
Forum topicTach display incorrect VMS200/DDEC-II Anonymous111 years 41 weeks ago
Forum topicCan't get the serial to usb adapter to work Anonymous211 years 41 weeks ago
Forum topicVMSpc and 400 ISL Anonymous211 years 42 weeks ago
Forum topicData Logging Anonymous111 years 42 weeks ago
Forum topiccummins 5.9 with 5 speed allison Anonymous211 years 44 weeks ago