Welcome to day-one for the new version. 4.0.9 changes and limited to a couple bug fixes and a couple goodies. Fixes: (this list will be appended as I sort out effectiveness) -- Found the bugs killing us on J1708. Fixed that. -- Created 'Radial' (round) gauges. Choose *either* "New Simple Gauge" or "New Radial Gauge". -- Added TST Tire Pressure Monitoring--with a new menu section "Settings" (under /Tires) -- Added "Fill Tank(s)" --To save you clicks and time. I didn't ask for the (s) ...yet a real bonus! Only have one? Hmmm.... -- Packed Drivers (as part of install) VMSpc is supposed to be completely portable. Now, it truly is. When it installs, a device-drivers folder is included. This way, when you copy your whole shebang onto a thumb-drive, the drivers will go with--rather than hunting around or downloading it again later. -- COM port/ Serial/ WiFi changes (causing a hang) is fixed as well. Sometimes the program would get stuck in a time-out which never ended (if the wrong/ missing jib was selected.) The Sample Layouts folder are not packed into the new build. That is still in a separate folder for now. ...work ongoing.... ================================================================= Your post must contain the Type and Operating system of your PC. # Tablet/ notebook or other -and- # XP, Vista, 7, 8, 8.1, 10... # Also, include your coach specs (year and engine-model) Posts missing this may get ignored--as it makes for more work to try to discover this... -thank you. :-) -Art

Submitted by tmorgan01 on Wed, 2018-10-03 12:47

Permalink

I installed 4.0.9 and all seems OK except The Transmission Indicator shows ?? when engine running. Deleted and reinstalled gauge. Engine type is "Cummins ISB XT (360 Hp).ENG" See signature for actual. Was using 4.0.8 and the Transmission Indicator showed just Gear Attained. Any ideas? Thanks Thomas TJ Morgan 2018 Discovery LXE 39F Freightliner XCM, Cummins ISB 6.7L VMCpc on RCA Cambio tablet

Submitted by tmorgan01 on Wed, 2018-10-03 13:19

Permalink

How is this integrated in 4.0.9? Thanks TJ Morgan 2018 Discovery LXE 39F Freightliner XCM, Cummins ISB 6.7L VMCpc 4.0.9 on RCA Cambio tablet, Win 10

Submitted by Marty Weston on Wed, 2018-10-03 21:59

Permalink

I have the same results as 1st poster. No values shown for any trans information. All other gauges appear to work normally. Using a generic Windows 10 tablet. Motor is a 2017 Cummins ISL, 450 HP on a Power Glide Chassis (Tiffin). Previous version did give me the "Gear Attained" info. I have the 500 baud data port, green plug.

Submitted by Art on Thu, 2018-10-04 09:06

Permalink

Good morning folks Thank you(!) for the timely feedback--Connor has found the transmission (non-report) bug and squashed it. v4.1 will be uploaded later this morning. The only change is a fix for this "??-transmission" bug. cheers Art //

Submitted by Art on Thu, 2018-10-04 09:17

Permalink

The TST implementation is a roll-out--in that it's done in several teps. The first step was (TST) fishing the core product to be able to interface with the J1939 engine bus (or RVC). Second step was to get it on a example product as a proof--done Third was adding it to the VMSpc code base; also done with v4.0.9. Now...this next step is a firmware change to allow for the extra messaging that TST needs to give more information. --More than PressurePro. So, the next step, in order to use the TST bridge unit, is to update the firmware in your JS501 jib to v1.15. Then, its just a matter of purchasing the equipment. I'm not sure how pricing works. While its all approved and now "In the software" that doesn't actually mean "In the warehouse." That info will be forthcoming, probably by way of the Silverleaf home page. ...stand by... cheers Art //

Submitted by Marty Weston on Thu, 2018-10-04 21:13

Permalink

OK, the updated installer for 4.1 took care of the missing Trans Gear info. Still just the "Gear attained" info, but I can live with that. I did notice a new gauge that I didn't have before. An "EGR Exhaust Gas Temp" PID 412 gauge in the PID list. It this new, or did I just miss it the first time around?

Submitted by 1CoolZ71 on Fri, 2018-10-05 13:32

Permalink

My 2005 Detroit Diesel is getting all the correct info but it updates really slow. Updates every 5 or 10 seconds, so it lags bad Using tablet with windows X

Submitted by rvdiver on Wed, 2018-10-10 09:18

Permalink

I installed 4.10. The transmission indicator only shows gear attained and a ? for gear selected. Still having trouble with the Cruise indicator which shows a blinking SET - ON SET - OFF for the first few seconds then just shows SET for the remainder of the time. Windows 10 RCA generic tablet. 2018 Newmar DS4018 ISL9-450

Submitted by PJHall on Thu, 2018-11-01 22:03

Permalink

Is 4.1 close to deployment yet? Available as beta perhaps? 2017 Freightliner/ Cummins 340 HP

Submitted by rustytools on Thu, 2018-11-15 05:04

Permalink

I'm anxiously waiting to build my screen layout with the round gauges, but I'm concerned that the 'real' 4.1 (when tank and odometer bugs get fixed) will overwrite everything and I'll have to start over. Or will it be transparent? And, any word on the TST implementation schedule/pricing? Thanks! Ron '08 Monaco Camelot, ISL400. RCA Cambio 10, Win10.

Submitted by Art on Fri, 2018-11-30 16:58

Permalink

Advanced: Dataloging: After selecting the wanted data items, most columns are missing some Title headings. Captures first few... HR, Min, Sec...Volts...Hours... then loses the rest. The columns of info are complete--just missing the headings. v4.08/ 9/ 4.1 [More info forthcoming]

Submitted by LarryB on Mon, 2019-02-25 11:45

Permalink

It has now been a number of months since it was announced that the latest release of 4.1 had a bug with the odometer reading. WHERE IS THE LATEST RELEASE WITH THIS FIX? Is there still someone there that is employed to work on this? I want to go to release 4.1 but since my odometer is reading incorrectly on my dash, I do not want to update to a release where VMSpc is putting out an invalid value. v4.07

Submitted by Where's Waldo on Tue, 2019-03-05 16:52

Permalink

I have been running v4.1 and had no issues, transmission indicator fine, odometer fine, tank minder running again after it stopped working in v4.08 and I had to roll back to v3.9. However, the refresh rate while running v4.1 is so slow its unusable, it will take 4 to 5 seconds for dials to change. I use VMSPC as my only dashboard so this causes me some major issues. without rebooting my tablet I am able to switch back to v3.9 and have a smooth display with no lag whatsoever so this has to be software related and something different in V4.1. Otherwise I love the new radial dials, the numbers are perfect size, please don't change them, the Cruise status actually works in this version for me. Windows Surface Pro 3, Windows 10 updated. Tiffin Phaeton 2005, Cat C7 350, USB Jib.

Submitted by acousticart on Mon, 2019-04-01 10:31

Permalink

I am still running v2.5 but would like to try the newest version understanding that it isn't regarded as a ready for prime time release. Is there a link? Also, what extra hardware/cabling is needed to utilize the TST TPMS 507 series tire pressure monitoring system?
Don

Submitted by 1CoolZ71 on Mon, 2019-06-10 08:35

Permalink

It's been over 9 months since version 4.1 came out. There are still freezing issues and other things.
My 3.6 version has the speed jumping up and down 3mph and the older versions are missing the nicer features.

Are you guys still a viable business? Website keeps going down and nothing updated in months.
I really like your software but may change to Bluefire, If you're not going to update any more.

2005 Detroit Diesel in a HR Navigator using a windows 10 computer

Submitted by Art on Thu, 2019-08-29 11:46

Permalink

Hello 1CoolZ71 and others...Art here...

Our business is flying right along--though the VMSpc makes up ~1/32nd of 1% of that, after 20 years, its still moving right along as well. Please understand, though important to both of us, it gets a fractional amount of a programmers' time for software work.

20 years in production. Many thousands of users. And, for 20 years we've had, essentially, the same code base with only adding, appending, adding USB...then Bluetooth, then wireless, patching...some recajiggering...and more patching until now. We stopped trying to 'fix' 4.0.8 --once we found that v4.1 couldn't do the things we wanted and remain scaleable.

Our programmer ran out of pasta sauce. He's building v5 now. We've been testing the early modules:

1. TPMS --he's dialing in better the TST system as that will be a go-to for tires. Secondarily Advantage PressurePro can be used, either bridge or gateway (J1708 or J1939).

2. Auto-COM --No more COM port stuff. The device driver will install during VMS program install. Then, when started, the COM port will be automatically ID'd and set. Data, at that point, will be seen at 'key-on.'

3. Selectable parsing. --We have many MANY coaches 2004~2006 with weird data. Oil pressure is steady on J1708, but speed is not. Speed and temps are steady on J1939 but OIL pres. and trans mode is erratic. On most (if not all gauges) you'll be able to select (like in the Communications Settings) J1708, J1939 or both.

4. Clipping --A new method to line up gauges and groups. When active, gauges wil 'stick' to each other to force an alignment. Makes for a quicker setup. This will be for both rectangular and radial (round) gauges.

I certainly understand your looking at another product; its great you have a secondary choice. However, this isn't a competition where social pressure can somehow make this our only and highest priority. 

cheers

Art

//